On 12 mars 09, at 23:00, Tudor Girba wrote:
It looks pretty good. Just a couple of remarks:
- The properties *Namespace: ScopingEntity should be named *Scope.
- The property Method>>parentClass: Type should be named parentType
- We should introduce Anchor as an Entity, and make
Entity>>sourceAnchor: Anchor. And we provide a
FileNameAndPositionAnchor by default, or something like that. Like
this we can also provide other kinds of Anchors in the future (like
image anchors, urls, or direct pointers to File objects).
Done in Moose-All 293
(well there is no concrete subclasses for SourceAnchor, but it is
there. And I just realize I named it SourceAnchor and not Anchor. Oh
On 7 Mar 2009, at 21:47, Simon Denier wrote:
> Dear list
> Here is the current version of the Famix3 metamodel, which should
> replace the slightly outdated pdf of beta14.
> Most importantly, we are asking for reviews, especially to check
> whether bidirectional relationships are correct.
> Moose-dev mailing list
"No matter how many recipes we'll know, we'll still value a chef."
Moose-dev mailing list