C/Cpp parser
by Nicolas Anquetil
Synectique is openning the source code for a C/C++ parser based on
Eclipse CDT.
https://github.com/Synectique/VerveineC-Cpp.git
The parser was developed as an Eclipse (Mars release) plugin and is
under MIT licence.
nicolas
--
Nicolas Anquetil -- MCF (HDR)
Project-Team RMod
5 years, 1 month
[Glamour] default selection in ListPresentation
by Cyrille Delaunay
Hello,
Is there a way to set a default selection to a list presentation? so that
when I open the browser, the morphic list has already a value selected.
I tried that:
|tmpBrowser|
tmpBrowser := GLMTabulator new.
tmpBrowser row: #list.
tmpBrowser transmit to: #list; andShow: [:a |
a list
display: [:input | input];
selection: #a;
yourself
].
tmpBrowser openOn: #( b c d v a d f r).
but the list still open with nothing selected
5 years, 2 months
Delegating views
by Luke Gorrie
Hoi,
What is the best way for an object to delegate one or more GTInspector
views to other objects?
I have been using a pattern like this:
gtInspectorFooIn: composite
<gtInspectorPresentationOrder: 5>
otherObject gtInspectorFooIn: composite
but I am wondering whether there is a better way, and also whether this
method is valid (I've occasionally seen odd behavior, like Inspector panes
disappearing after I "Refresh", and I wonder if I could be somehow
confusing the model or if this is not relevant.)
also: Supposing this pattern is valid, is there an easy way to override the
title of the view(s) added by otherObject?
5 years, 5 months
Users of TDependencyQueries
by Cyril Ferlicot
Hi,
Currently Moose-Query works with Traits.
There is :
- TDependencyQueries containing all the query system and the common
queries such as #queryIncomingAccesses
- TOODependencyQueries using TDependencyQueries and adding the method
specific to OO entities (mostly inheritance queries)
The users of TDependencyQueries are:
- TOODependencyQueries
- FAMIXAnnotationInstance
- FAMIXAnnotationInstanceAttribute
- FAMIXSourceAnchor
The users of TOODependencyQueries are:
- FAMIXNamedEntity
I think it would make sense to move TDependencyQueries to FAMIXEntity.
FAMIXEntity has all the API needed to the queries and it would help
with the consistancy. For example I think that all famix entities
should be able to answer to "queryAllIncomingAssociations". It would
felp making more generic tools.
What do you think? Does that bother someone?
--
Cyril Ferlicot
https://ferlicot.fr
http://www.synectique.eu
2 rue Jacques Prévert 01,
59650 Villeneuve d'ascq France
5 years, 7 months
Improvement on DistributionMap
by Anne Etien
Hi,
I find how to easily do one Distribution map from elements.
However, as you can see, it is not very beautiful.
- Is there an easy way to get legend on distribution map? Here each color corresponds to an author, but if I don’t say it to you you can’t invent it.
- the labels are too long, there are the result of element printString and not of element mooseName. How can I change that?
- I would also like to be able to inspect each element when clicking on it. But once again, since DistributionMap doesn’t inherit from any Roassal element, I don’t know how to do it.
Can anyone help me?
Thanks in advance.
Anne
5 years, 7 months
Management of #queryAll{Direction}Associations (complete one)
by Cyril Ferlicot
Hi!
Sorry for my previous incomplete mail. I missclicked. Here is the full one:
I have some improvements I would like to make to Moose query and I
would like your approuval.
First. Currently there is:
- #queryAllOutgoing and #queryAllOutgoingAssociations to query all the
outgoing associations of the receiver
- #queryAllIncoming and #queryAllIncomingAssociations to query all the
incoming associations of the receiver
#queryAll{Direction} is based on the meta-model properties while
#queryAll{Direction}Associations seems to be more empirical.
See:
queryAllOutgoingAssociations
^ self queryStaticOutgoingAssociations
addAll: self queryAllOutgoingInvocations;
yourself
I propose two changes:
- Remove the empirical implementation to use only the one based on the
meta-model
- Deprecate #queryAllIncoming and #queryAllOutgoing. I think
#queryAllIncomingAssociations is a better name, but I can change my
mine if you have a different opinion on that.
Second. To query all the in/out associations with the method based on
the meta-models, there is the use of "FAMIXAssociation
withAllSubclassesDo:" to iterate on the associations and do the
queries for all of them.
I have three problems with that:
- This is not efficient. If an entity can have only 2 incoming
associations it will still try the queries for all the associations in
the image
- This has a role in the circular dependency between FAMIX-Core and
Moose-Query packages because we reference FAMIXAssociation
- If one day we create another project from FAME to represent
something that is not a software model, we will maybe not have
FAMIXAssociation but we might still have associations. And Moose-Query
could still be useful on this project.
I propose to add to TEntityMetaLevelDependency two methods:
allOutgoingAssociationTypes
^ (self allChildrenTypes flatCollectAsSet: #outgoingAssociationTypes)
addAll: self outgoingAssociationTypes;
yourself
and
allIncomingAssociationTypes
^ (self allChildrenTypes flatCollectAsSet: #incomingAssociationTypes)
addAll: self incomingAssociationTypes;
yourself
Thus the entities will be able to return the associations they and
their children can have.
Then we can replace "FAMIXAssociation withAllSubclassesDo:" by "(self
strategy allAssociationTypesFor: anEntity)
do:" where the strategy is a MooseQuery{Direction}DirectionStrategy
that will call either #allIncomingAssociationTypes or
#allOutgoingAssociationTypes.
I have an image with all those changes and all the tests of
Moose-Query and Moose-Chef are green.
I am waiting your opinion on this changes.
Have a nice day.
--
Cyril Ferlicot
https://ferlicot.fr
http://www.synectique.eu
2 rue Jacques Prévert 01,
59650 Villeneuve d'ascq France
5 years, 7 months
RTExampleFactory is missing sourceClass:
by Alexandre Bergel
Hi!
How can I update GTExample?
Why not having a "GToolkit update” world menu entry, somewhere?
Cheers,
Alexandre
--
_,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
Alexandre Bergel http://www.bergel.eu
^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
5 years, 7 months
Cannot update GLMTabulator containing list with Separators
by Peter Uhnák
Hi,
apparently it is not possible to update a GLMTabulator if it contains a
list pane with separators. Tested in P6 & P7.
```
data := { { #one. #two. #three } asOrderedCollection. { #alpha. #beta }
asOrderedCollection } asOrderedCollection.
browser := GLMTabulator new.
browser column: #list; column: #actions.
browser transmit to: #list; andShow: [ :a |
a fastList
withSeparators
].
browser transmit to: #actions; andShow: [ :a |
a actionList
act: [ :actionList | data last add: #dynamic. browser update ] entitled:
'Add Item';
act: [ :actionList | data last remove: #dynamic ifAbsent: [ ]. browser
update ] entitled: 'Remove Item'.
].
browser openOn: data.
```
[image: Inline image 1]
Thanks,
Peter
5 years, 7 months
GLMTabulator buttons
by Peter Uhnák
Hi,
I went through the GLM examples and the chapter (
http://pharobooks.gforge.inria.fr/PharoByExampleTwo-Eng/latest/Glamour.pdf
) however none of them mention any of the following.
Is it possible to change the width of an action button? It seems that the
width is fixed.
[image: Inline image 1]
Likewise is it possible to change the layout, so the buttons are on top of
each other and not side-by-side?
Finally it seems that setting icons does not work; tested in Pharo 6 and
Pharo 7: (screenshot above). Maybe it works only for the toolbar icons?
browser := GLMTabulator new.
browser column: #one.
browser transmit to: #one; andShow: [ :a |
a actionList
act: [:entity | entity inspect ] iconName: #glamorousInspect entitled:
'Longer Button Label...';
act: [:entity | entity explore ] icon: #glamorousOpen asIcon entitled:
'Explore'].
browser openOn: 42.
Any pointers appreciated,
Peter
5 years, 7 months
Inspector Presentation?
by Sean P. DeNigris
I've found the following idiom (or parts of it) to be repeatedly useful:
browser transmit
...
andShow: [ :a :b | a finder show: [ :b :object | object
gtInspectorPresentationsIn: b inContext: GTInspector new ] ]
I wonder if it's worth reifying into the DSL. I first thought `a inspector`,
but it seems Object already implements it to open an actual... inspector ;)
-----
Cheers,
Sean
--
Sent from: http://forum.world.st/Moose-f1310756.html
5 years, 7 months