Hi
I'm looking for a good name which covers both package and namespace concepts. 'ScopingEntity' sounds a bit too verbose.
The reason is that today, we have queries like clientClassesOutOfMyPackage, clientClassesOutOfMyNamespace. There are strong similarities between such queries so that it can actually be written once and reused multiple times. Tomorrow, I want such queries to be defined in a trait and injected in both FamixPackage and FamixNamespace. But, I want a single good name to name both Namespace and Package. Container?
-- Simon
I'm looking for a good name which covers both package and namespace concepts. 'ScopingEntity' sounds a bit too verbose.
The reason is that today, we have queries like clientClassesOutOfMyPackage, clientClassesOutOfMyNamespace. There are strong similarities between such queries so that it can actually be written once and reused multiple times. Tomorrow, I want such queries to be defined in a trait and injected in both FamixPackage and FamixNamespace. But, I want a single good name to name both Namespace and Package. Container?
I thought about "Container" before reaching the end of your email
Alexandre
Container exists already, so that is not good.
How about Scoper? :)
Doru
On 19 Aug 2010, at 16:23, Simon Denier wrote:
Hi
I'm looking for a good name which covers both package and namespace concepts. 'ScopingEntity' sounds a bit too verbose.
The reason is that today, we have queries like clientClassesOutOfMyPackage, clientClassesOutOfMyNamespace. There are strong similarities between such queries so that it can actually be written once and reused multiple times. Tomorrow, I want such queries to be defined in a trait and injected in both FamixPackage and FamixNamespace. But, I want a single good name to name both Namespace and Package. Container?
-- Simon
Moose-dev mailing list Moose-dev@iam.unibe.ch https://www.iam.unibe.ch/mailman/listinfo/moose-dev
-- www.tudorgirba.com
"Presenting is storytelling."
On 19 août 2010, at 16:34, Tudor Girba wrote:
Container exists already, so that is not good.
How about Module? But it has other implications...
How about Scoper? :)
ergh :) well, perhaps it will win by default.
Doru
On 19 Aug 2010, at 16:23, Simon Denier wrote:
Hi
I'm looking for a good name which covers both package and namespace concepts. 'ScopingEntity' sounds a bit too verbose.
The reason is that today, we have queries like clientClassesOutOfMyPackage, clientClassesOutOfMyNamespace. There are strong similarities between such queries so that it can actually be written once and reused multiple times. Tomorrow, I want such queries to be defined in a trait and injected in both FamixPackage and FamixNamespace. But, I want a single good name to name both Namespace and Package. Container?
-- Simon
Moose-dev mailing list Moose-dev@iam.unibe.ch https://www.iam.unibe.ch/mailman/listinfo/moose-dev
-- www.tudorgirba.com
"Presenting is storytelling."
Moose-dev mailing list Moose-dev@iam.unibe.ch https://www.iam.unibe.ch/mailman/listinfo/moose-dev
-- Simon