Hi
I have Roassal as speed with 30,000 elements as with 1,000 elements.
But still I have to udpate the view when resizing the window and
translating the view.
Does anyone know how to send the view an event when I resize the view ?
Regards
Mathieu
Hi,
The isPackage method is implemented only in FAMIXNamedEntity (and obviously in FAMIXPackage).
The isClass method is implemented only in FAMIXSourcedEntity (and obviously in FAMIXClass).
The isAttribute method is implemented only in FAMIXStructuralEntity (and obviously in FAMIXAttribute).
The isMethod method is not implemented…
Why not harmonizing this and defining all these methods in FAMIXEntity?
In fact, I am working with Nicolas Anquetil on the diff of models. I would like to create an Orion action for each change. Thus, if a class is added between version n and version n+1, I would like to instantiate an AddClass operator. And so on for each change. So I need to know the type of the FAMIXEntity on which the change occurred. Using these methods would be tidier than using isKindOf: method.
Please let me know if such implementations make sense for you or not.
Anne
Hi all,
I try to make sense of Petit Java and the discussions around it, because it makes sense to have a similar architecture for Petit Delphi. The Delphi syntax contains 141 rules, versus 137 rules in java. So we compare pretty closely. But when I try to read the petit java code, I notice some odd things, so maybe someone can tell me why things are as they are.
I thought AST meant we have an Abstract Syntax Tree. A syntax tree, that only contains the information needed. The way we do it on the Delphi side, is that only when we have a purpose for a certain AST Node we create it. On the detail level, we do not have many AST nodes yet, since we only generate FAMIX to the method level. And the number of AST nodes is growing fast. Why does the AST needs to stick to the java grammar as closely as possible?
When I look at the AST Node and at the places where they are created, they more look like grammar nodes than syntax nodes. I have a node called MethodDeclarationNode. But it is created in the rule "methodNotConstructorDeclaration" and when I look at the rule "methodDeclaration" I would expect to have 2 subclasses: a ConstructorDeclarationNode and a MethodNotConstructorDeclarationNode … but instead I have a subclass InterfaceMethodDeclarationNode. I thought FAMIX was meant for this and that is why we convert our AST into FAMIX as well …
In PetitJava there is a visitor for the AST. I do not see how this visitor helps. The AST is changing faster than the implementors of the visitor, not only because we are evolving Petit Java, but also because Java itself also evolves and will make changes to the language in the future. I see only a few possible implementors of this visitor.
And maybe some of the Petit Java developers want to take a look at the Petit Delphi code. Because I am sure we did things good and also some stupid things, so please help us find the stupid things and copy the good things! I know I try to copy the good ideas from petit java.
Regards,
Diego
Hi
I'm working on Radial tree to make ti take node size into
account.
I've tried some few things about mixing layout, and it seems
to work. (I'll commit it in the week, and send you a mail then)
Then I
have some questions :
If the layout can't change node size, then what
can do it ? Is it the aim of Normalizers ?
Status: New
Owner: ----
Labels: Type-Defect Priority-Medium Component-Glamour Milestone-4.7
New issue 800 by tudor.gi...(a)gmail.com: Glamour browsers do not respond to
browser-global keybindings
http://code.google.com/p/moose-technology/issues/detail?id=800
Essentially, window does not seem to be affected by this line:
window on: #keyStroke send: #handleKeyStroke: to: window.
This seems to be a Pharo 1.4 related issue.
Hi,
As you might have noticed, I started to go issues that are currently open
and see if any of these can be closed. I managed to close a few.
I would welcome any of you to join the effort :).
And we are due with 4.8. I did not manage last week, but I will try this
week. In particular, we would need to deal with this issue:
Issue 950: Freeze 4.8
https://code.google.com/p/moose-technology/issues/detail?id=950
Anyone wants to join the effort?
Cheers,
Doru
--
www.tudorgirba.com
"Every thing has its own flow"
Status: New
Owner: ----
Labels: Type-Engineering Priority-Medium Milestone-4.7
New issue 853 by tu...(a)tudorgirba.com: ConfigurationOfMoose should be split
to reflect core vs suite
http://code.google.com/p/moose-technology/issues/detail?id=853
Right now, in ConfigurationOfMoose we have two methods:
- coreDefault
- default
These should be the basis for splitting into two distinct configuration
classes.
Ideally, we would rename ConfigurationOfMoose to ConfigurationOfMooseSuite,
but this is difficult due to the many scripts that depend on the current
name. So, we will not do that (at least not now).
Also, in the process of splitting, we will remove the 'default' version and
transform it into a baseline.
Johan wrote:
>So, yes, stick to the language spec. Some PhD student will be glad for it at some later time!
Ok, so that problem we don't have in Delphi. There is no spec,
and all available grammars are wrong. AFAIK, most languages have either that
problem, or no significant implementations that follow the spec (c++, sql).
Chris doesn't seem opposed to a very detailed level, as long as there
are some convenience accessors in the right places. Our problem
with PetitDelphi is that there is no way to know what nodes to create,
without having a usecase for them. So we just started (like Chris, I guess)
with what we seemed to need.
Stephan