Hi!
It would be great to get feedback from you guys.
We have the class TRConstraint that allows for roassal elements to be aligned (cf Section
10 in
https://dl.dropboxusercontent.com/u/31543901/AgileVisualization/Roassal/010…
<https://dl.dropboxusercontent.com/u/31543901/AgileVisualization/Roassal/0104-Roassal.html>).
Currently, you can write:
TRConstraint use: centralDot alignFromTop: negativeElements
Which align all the elements contained in the collection negativeElements against a fix
point, centralDot.
It looks pretty easy to read. However, the class TRConstraint has many methods
(alignFromBottom:, alignFromLeft:, use: aShape alignFromBottom: shapes, …) which are
essentially all duplicated code.
So, I though about creating a compact class, called RTAlignment. You can now write:
RTAlignment new elements: negativeElements; fixedElement: centralDot; top
But, I find that less nice to read. Any opinion?
Cheers,
Alexandre
--
_,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
Alexandre Bergel
http://www.bergel.eu
^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.