On Fri, Jul 31, 2015 at 2:34 PM, Alexandre Bergel <alexandre.bergel(a)me.com>
wrote:
Hi!
It would be great to get feedback from you guys.
We have the class TRConstraint that allows for roassal elements to be
aligned (cf Section 10 in
https://dl.dropboxusercontent.com/u/31543901/AgileVisualization/Roassal/010…
).
Currently, you can write:
TRConstraint use: centralDot alignFromTop: negativeElements
Which align all the elements contained in the collection negativeElements
against a fix point, centralDot.
It looks pretty easy to read. However, the class TRConstraint has many
methods (alignFromBottom:, alignFromLeft:, use: aShape alignFromBottom:
shapes, …) which are essentially all duplicated code.
So, I though about creating a compact class, called RTAlignment. You can
now write:
RTAlignment new elements: negativeElements; fixedElement: centralDot; top
But, I find that less nice to read. Any opinion?
Cheers,
Alexandre
TRConstraing align: negativeElements using: (RTAlignment top against:
centralDot)
?
From your original list, I'd be more likely to want
to use your first
example. But then, I'm used to lots of methods.
-cbc