Hi,
I went quickly through the PetitJava implementation and I stumbled
across the keywords implementation. I would propose a simpler solution:
keyword
^ (arrayOfKeywords inject: PPEpsilonParser new not into: [:p :key |
p / key asParser ]) token trimBlanks .
Now the question is if it makes sense to have a separate parser class
equivalent to PPEpsilonParser new not. If yes, what would a good name
be?
Cheers,
Doru
--
www.tudorgirba.com
"Speaking louder won't make the point worthier."