I think that this is more than just having correct/good comments....
is the parameter passed to edges: consistent? I do not think so
at least from what I understood
edges: from: to:
and
aView edges: someFamixInvocations from: #sender toAll: #candidates
show different cases.
Now if nodes: except a collection of entities playing the node role
why edges is not a collection of antities playing edges role?
Corollary why in some cases this is the case and in other not?
Now the comments are absent and not consistent: "aCollection is the collection of
edges to represent." is it correct?
edges: aCollection from: aFromBlock
"- aCollection is the collection of edges to represent.
- aFromBlock will be called on each element of the collection and return one edge source
each time.
Note that there is no restriction on the elements of aCollection, as long as aFromBlock
returns a node.
"
aCollection is a bad name for an argument.
Same here..... even if this is a bit better because there is one example showing that the
comment is not wrong.
edges: aCollection from: aFromBlock toAll: aToBlock
"- aCollection is the collection of edges to represent.
- aFromBlock will be called on each element of the collection and return one edge source
each time.
- aToBlock will be called similarly to return a collection of destination correpsonding
to each source.
Note that there is no restriction on the elements of aCollection, as long as aFromBlock
returns a node and aToBlock returns a collection of nodes.
For example:
aView edges: someFamixInvocations from: #sender toAll: #candidates
aToBlock should return a collection, edges will be drawn from the element returned by
aFromBlock to this collection"
^self edges: aCollection from: aFromBlock toAll: aToBlock using: self edgeShape
Stef