When I am rendering a model using "MYQueryModel new asComponent", I want the
text on the Magritte-generated form's 'Save' button to read something else
like 'Search'. How do I do this, if it is even possible. I am trying to
use descriptions for a query object and want the same action as the default
'Save' (to answer the object) , but having a button with that label will
confuse users.
Thanks in advance.
Chad
Some people reported problems loading the latest version of Magritte.
I renamed a class that registered for system-change notifications and
during the load-operation of Monticello it points to an obsolete
class making it impossible to compile any method in the system.
To solve the problem simply evaluate the expression below, before
loading a recent version of Magritte:
MABuilder allSubInstancesDo: [ :each |
SystemChangeNotifier uniqueInstance
noMoreNotificationsFor: each ].
Smalltalk garbageCollect.
Sorry for the inconveniance!
Cheers,
Lukas
--
Lukas Renggli
http://www.lukas-renggli.ch
Hi Frank,
> With some easy things in css I was able to realize what I want in
> HTML. But what do you think about syntax extension of pier to do
> such things like
> :indented_text.
> I found this behavior in another wiki and it helps for readability
> of the text.
> Sure I can use HTML but writing of such things written above is
> much easier.
I tried to keep the syntax as simple as possible. However there were
several requests lately for that kind of things. I don't really know,
how we could implement that the simplest without bloating the wiki-
syntax and while keeping the visitors small that transform the AST
into different output-formats (HTML, Text, Latex, etc).
The best idea I cam up so far is to add some sort of XML-Tags that
can be parsed in a generic fashion, so that extensions can register
their own tags. Something along ...
<pier:indented>
The time is now: <pier:smalltalk>Time now</pier:smalltalk>
</pier:indented>
Would that help? Is something like that of generic interest?
> I've been searching in the code for the place of translation from
> *..* and others to HTML and coming down to PRDocumentScanner
> scanForToken and see the scannerDefinitionComment on class-side.
> The next step to define a new element would be very interesting.
The scanner and parser is automatically generated from the respective
definitions using SmaCC, so you probably don't want to change these
methods manually ;-)
If you only want to do some simple string transformations when
generating HTML you could simply patch the methods from the protocol
#visiting-document in the class PRViewRenderer.
Cheers,
Lukas
--
Lukas Renggli
http://www.lukas-renggli.ch
Hi, Lukas!
I can understand that a simple syntax keep it easy writing some content.
My intention was keeping fingertips writing my ideas in the wiki. On the other
side the idea using some sort of XML-tags bring us the possibility write
some extensions like a building set.
I'm not so familiar with XML but in my understanding of this we could bring
the translation to other formats into the tags. With an open repository of
these buildingblocks everybody can decide what he want.
The loosers in this kind of solution are my fingers ;-).
> > Sure I can use HTML but writing of such things written above is
> > much easier.
>
> I tried to keep the syntax as simple as possible. However there were
> several requests lately for that kind of things. I don't really know,
> how we could implement that the simplest without bloating the wiki-
> syntax and while keeping the visitors small that transform the AST
> into different output-formats (HTML, Text, Latex, etc).
>
> The best idea I cam up so far is to add some sort of XML-Tags that
> can be parsed in a generic fashion, so that extensions can register
> their own tags. Something along ...
>
> <pier:indented>
> The time is now: <pier:smalltalk>Time now</pier:smalltalk>
> </pier:indented>
>
> Would that help? Is something like that of generic interest?
>
> > I've been searching in the code for the place of translation from
> > *..* and others to HTML and coming down to PRDocumentScanner
> > scanForToken and see the scannerDefinitionComment on class-side.
> > The next step to define a new element would be very interesting.
>
> The scanner and parser is automatically generated from the respective
> definitions using SmaCC, so you probably don't want to change these
> methods manually ;-)
My mistake. Is it possible to add a comment "Do not touch, it's generated"?
Cheers,
Frank
> If you only want to do some simple string transformations when
> generating HTML you could simply patch the methods from the protocol
> #visiting-document in the class PRViewRenderer.
>
> Cheers,
> Lukas
>
> --
> Lukas Renggli
> http://www.lukas-renggli.ch
>
>
>
>
Hi all,
I want to indent some parts of text in pier. But I didn't see in the syntax-introduction these things. Can anybody advise me for this.
Thanks in advance.
Cheers,
Frank
Hi,
I'm new to smalltalk, seaside and pier. I want to use pier to host a small
site, and if possible, I'd like to change the way internal links to other
pages are rendered, so that the wiki text:
*Introduction>introduction*
produces the link:
http://localhost:9090/seaside/pier/information/introduction
instead of:
http://localhost:9090/seaside/pier/information/introduction?view=PRDefaultV…
Both links return the same URL when typed into the browser, so clearly
view is the default command. I've tried searching around for information
about this but I couldn't find anything obvious to me. While browsing the
source code, I came across WAUrl adaptToContext: and WAAnchorTag goto:,
which look potentially relevant, but I'm honestly not sure if I'm on the
right track. I'd appreciate it if someone could point me in the right
direction. Also, if this is a really bad idea for some reason, that would
also be good to know.
I'm using Sqeak-3.8, Seaside 2.63a3-lr.51 and Pier-all-lr.81
Thanks,
Brian