Honestly, maybe
it's a culture difference, but damned if I
don't have a
description accessor on tons of my domain objects,
summary
doesn't feel
right to me. I was just thinking something
that's less common than
description, that's just so generic a term and so common for an
accessor. Even something similar that is more behavioral
sounding like
descriptor, or, really, a conversion method like
asDescrition or
asDescriptor rather than just description. It's not really
an accessor
anyhow, it's building a description of the
object and
returning it as a
container, so a conversion method seems
reasonable. Thoughts?
How about #descriptions which is a common naming for
collections of anything ?
I would even prefer that, since I don't see myself as having collisions
with it, but I really do feel it should be a conversion method. When
you want a component, you say anObject asComponent, when you want a
description, why not anObject asDescription? The description isn't a
property of the object, it's a different representation of it, a meta
representation.