I'm playing with porting an existing model driven application to
magritte and I'm hitting very frequent conflicts on the method name
#description. I would urge you to change this in the future to
something less generic like modelDescription.
Yep, that has been discussed several times already. I've got a list
of many other selectors, that would be less likely to conflict. My
favorite one is still #descriptor.
What hinders me to change it right now is that there are many big
(commercial) projects relying on Magritte. It will be certainly
changed in the next big version, but probably not today or tomorrow.