Though, I do want to mention, it's always bothered me that you
chose description as an accessor for getting at the metaModel,
since description is probably one of the most used accessors to
put onto a domain object, along with name. I think description
is too generic and useful a term to use it as an extension
to the instance side of Object, what do you think?
Do you have a better suggestion on how to name it?
I was looking for a word that does not include 'meta' as a substring
(I think it is already used too often in different contexts) and that
reads well and tells what it is used for. #description was the best
thing I could find.
In real live I only observed once having an accessor that was called
#description and then I could change that together with the author to
be something like #summary. I think every method extension sooner or
later conflicts with existing software.
Another thing, probably out-of-topic in this thread, is how you
should call accessors, if you have an object referencing an external
description, such as MAValidationError. I simply called it
#description, even-tough this description does not describe the
receiver. I probably should have called it #actualDescription or
#targetDescription or #externalDescription or ... I was too lazy at
the moment. However this problem stays the same, even if I replace
the #description-prefix with any other.