No problem Tudor!

So.. I tried to parse the system using inFusion. It seems that it generates "more correct" a mse file, but still not perfect:

I followed the instructions and generated the mse file [ ].
When I try to import it in VW based Moose:
- it correctly does the first pass ( "Reading 17 MB from input stream..." ) [and this was the part that raised the exception using the mse file generated by iPlasma]
- it correctly does also the second one ( "Importing 105029 elements..." )
- it raises an exception during the third pass ( "Importing attributes and assocations..." ): "Unhandled exception: CodeFoo.AssertionFailure"

looking at the calls before the exception, you can see a message "mmSetAll:collection:" sent to a "SCG.Moose.FAMIXAnnotationInstance" object. So, probably, the annotations are still problematic.

Thanks for your help!

2009/7/22 Tudor Girba <>

Ohh, I am sorry but I gave you the wrong url :(

Could you try again following this:


On 22 Jul 2009, at 08:58, Alberto Bacchelli wrote:

> Hi Doru,
> I (successfully) tried to reproduce the problem again:
> - I used the sources that you can find in
> - I followed the steps in
> - I exported the mse file, which you can also find in
> - I tried to import it in Moose, in VisualWorks 7.6nc
> The problem is still there: "Unhandled exception: Unknown character".
> If you look at my previous mails, you can see how I tried to spot
> the cause of this exception.
> At the end, I noticed that:
> It seems that iPlasma generates a mse file that it considers valid,
> however Moose on VW 7.6nc does not agree :)
> This issue is probably caused by annotation (in the java sense).
> Ciao,
> Alberto
> 2009/7/21 Tudor Girba <>
> Hi Alberto,
> I tried to reproduce the problem with the new inFusion, but I could
> not reproduce the problem. Could you try again following:
> Cheers,
> Doru
> [...]
> _______________________________________________
> Moose-dev mailing list


"Beauty is where we see it."

Moose-dev mailing list